Exa - Websets enrichments degraded – Incident details
Report an issue
Get updates
Email
Slack
Google Chat
Webhook
API
Report an issue
Get updates
All systems operational
Websets enrichments degraded
Resolved
Partial outage
Started 2 months ago
Lasted about 8 hours
Affected
Websets
Partial outage from 3:03 AM to 11:30 AM
Updates
Resolved
February 25, 2026 at 11:30 AM
Resolved
February 25, 2026 at 11:30 AM
This incident has been resolved.
Investigating
February 25, 2026 at 3:03 AM
Investigating
February 25, 2026 at 3:03 AM
We are currently investigating this incident.