Exa - Crawling system overwhelmed, leading to very high failure rates – Incident details
Report an issue
Get updates
Email
Slack
Google Chat
Webhook
API
Report an issue
Get updates
All systems operational
Crawling system overwhelmed, leading to very high failure rates
Resolved
Major outage
Started 4 days ago
Lasted about 5 hours
Updates
Resolved
June 09, 2025 at 5:30 PM
Resolved
June 09, 2025 at 5:30 PM
We have restored the crawling system
Investigating
June 09, 2025 at 1:00 PM
Investigating
June 09, 2025 at 1:00 PM
Our crawling system was overwhelmed and crawling was down