Exa - Elevated latency in Fast / Auto Search – Incident details
Report an issue
Get updates
Email
Slack
Google Chat
Webhook
API
Report an issue
Get updates
All systems operational
Elevated latency in Fast / Auto Search
Resolved
Degraded performance
Started 26 days ago
Lasted about 1 hour
Updates
Resolved
January 15, 2026 at 3:50 PM
Resolved
January 15, 2026 at 3:50 PM
This incident has been resolved.
Identified
January 15, 2026 at 3:30 PM
Identified
January 15, 2026 at 3:30 PM
We are continuing to work on a fix for this incident. A temporary mitigation has been applied.
Investigating
January 15, 2026 at 2:30 PM
Investigating
January 15, 2026 at 2:30 PM
We are currently investigating this incident.